Depeche Mode Forum S'enregistrer Se connecter pour vérifier ses messages privés Profil FAQ Liste des Membres Rechercher Groupes d'utilisateurs
Depeche Mode Forum
Information Comment faire resortir les doublons dans un fichier Excel ?

Poster un nouveau sujet Répondre au sujet
Depeche Mode Forum » Bla-Bla » Aide   
Voir le sujet précédent :: Voir le sujet suivant
AuteurMessage
Manu2

Forum en viager

Forum en viager



Inscrit le: 07 Déc 2002
Messages: 2049

Sujet du message: Comment faire resortir les doublons dans un fichier Excel ? Répondre en citant

Bonsoir,

J'ai un *#&@ de fichier Excel Twisted Evil qui comporte des erreurs, à tous les coups à cause de doublons. Savez-vous comment les faire apparaître sans me palucher à la main des milliers de lignes ?

J'ai regardé à la va-vite sur le net, mais pas trouvé...

Merci pour vos réponses !
_________________
"Je trouve qu'il vaut mieux faire des fautes d'orthographe que des fautes de goût" - Rachid Taha
Posté le:
Mar 29 Mai 2007 à 22:36
Top of PageVoir le profil de l'utilisateurEnvoyer un message privé
yoann

Free Mind




Inscrit le: 26 Nov 2002
Messages: 5204
Lieu : Au dessus de votre tête

Sujet du message: Répondre en citant

as tu une "clé" simple (pas une clé multiple sur 50 colonnes) dans to fichier Excel ?
_________________
Tanféssémalassur man ©
Posté le:
Mer 30 Mai 2007 à 8:07
Top of PageVoir le profil de l'utilisateurEnvoyer un message privéEnvoyer l'e-mail
stef 8698

Forum en viager

Forum en viager



Inscrit le: 08 Jui 2003
Messages: 1830
Lieu : Derrière mes fourches!

Sujet du message: Répondre en citant

yoann a écrit:
as tu une "clé" simple (pas une clé multiple sur 50 colonnes) dans to fichier Excel ?


Euh, je ne sais pas ce que tu entends par clé ? Un champ unique qui définit chaque ligne ? Si c'est ça, oui : une colonne qui reprend le code de chaque article.
_________________
Delta Muppets Tour.
Posté le:
Mer 30 Mai 2007 à 13:26
Top of PageVoir le profil de l'utilisateurEnvoyer un message privéSkype
STUMM






Inscrit le: 03 Déc 2002
Messages: 7858

Sujet du message: Répondre en citant

tu as essayé d'appliquer un filtre simple?
_________________
Angels never die... Get ready for a new era
www.playingtheangel.com
Posté le:
Mer 30 Mai 2007 à 13:50
Top of PageVoir le profil de l'utilisateurEnvoyer un message privéVisiter le site web du posteur
Manu2

Forum en viager

Forum en viager



Inscrit le: 07 Déc 2002
Messages: 2049

Sujet du message: Répondre en citant

J'ai pas eu beaucoup de temps pour m'y pencher dessus. En plus l'ordi sur lequel je retravaille ce fichier Excel n'a pas d'accès internet... Evil or Very Mad Apparemment une option "filtre élaboré" permet d'extraire les données "sans doublon". Je n'ai pas essayé, mais ce n'est pas vraiment ce que je souhaite. En fait, je veux isoler les doublons pour approfondir ma vérification et remonter à la source qui doit être mauvaise, car elle ne doit en aucun cas en comporter. Pour cela, il me faut bien connaître les doublons, et non pas les éradiquer purement et simplement.
_________________
"Je trouve qu'il vaut mieux faire des fautes d'orthographe que des fautes de goût" - Rachid Taha
Posté le:
Mer 30 Mai 2007 à 23:25
Top of PageVoir le profil de l'utilisateurEnvoyer un message privé
yoann

Free Mind




Inscrit le: 26 Nov 2002
Messages: 5204
Lieu : Au dessus de votre tête

Sujet du message: Répondre en citant

Ci joint un exemple
Une clonne "clé" avec des doublons
On voit des doublons pour les valeurs "2" et "5"

Si tu te crée une colonne avec la formule suivante tu poutrras isoler les doublons.
=SI(A2=A3;0;1) et que tu fais glisser ça fera pour la 2eme occurence :
=SI(A3=A4;0;1) etc....

Filtrer ensuite sur la valeur 1 pour dédoublonner.
(Le fichier doit impérativement etre trié sur la clé)

Mais c'est peut etre pas ça que tu souhaites. Exclamation Question


_________________
Tanféssémalassur man ©
Posté le:
Jeu 31 Mai 2007 à 8:24
Top of PageVoir le profil de l'utilisateurEnvoyer un message privéEnvoyer l'e-mail
Manu2

Forum en viager

Forum en viager



Inscrit le: 07 Déc 2002
Messages: 2049

Sujet du message: Répondre en citant

yoann a écrit:
Ci joint un exemple
Une clonne "clé" avec des doublons
On voit des doublons pour les valeurs "2" et "5"

Si tu te crée une colonne avec la formule suivante tu poutrras isoler les doublons.
=SI(A2=A3;0;1) et que tu fais glisser ça fera pour la 2eme occurence :
=SI(A3=A4;0;1) etc....

Filtrer ensuite sur la valeur 1 pour dédoublonner.
(Le fichier doit impérativement etre trié sur la clé)

Mais c'est peut etre pas ça que tu souhaites. Exclamation Question



Ah oui, c'est effectivement une méthode simple pour détecter les doublons. Je pensais qu'il y avait une fonction dédiée, mais cette formule est super ! Merci !!!

Smile
_________________
"Je trouve qu'il vaut mieux faire des fautes d'orthographe que des fautes de goût" - Rachid Taha
Posté le:
Jeu 31 Mai 2007 à 13:21
Top of PageVoir le profil de l'utilisateurEnvoyer un message privé
yoann

Free Mind




Inscrit le: 26 Nov 2002
Messages: 5204
Lieu : Au dessus de votre tête

Sujet du message: Répondre en citant

je t'envoi un RIB ? Hilare
_________________
Tanféssémalassur man ©
Posté le:
Jeu 31 Mai 2007 à 19:44
Top of PageVoir le profil de l'utilisateurEnvoyer un message privéEnvoyer l'e-mail
Montrer les messages depuis:   
Toutes les heures sont au format GMT + 2 Heures
Poster un nouveau sujet Répondre au sujet
Depeche Mode Forum » Bla-Bla » Aide  

Sauter vers:  
Key
  Vous ne pouvez pas poster de nouveaux sujets dans ce forum
Vous ne pouvez pas répondre aux sujets dans ce forum
Vous ne pouvez pas éditer vos messages dans ce forum
Vous ne pouvez pas supprimer vos messages dans ce forum
Vous ne pouvez pas voter dans les sondages de ce forum

PhpBB Modecelebration - All rights very much reserved 1999 - 2037 | Greetz to Raphmode.net for the fonts | Contact | Flux RSS